Google Image Traffic Shows Significant Drops, Is It A Bug?

Sep 16, 2015 • 8:29 am | comments (13) by twitter Google+ | Filed Under Google Search Engine
 

I am hearing reports from international sources both in Germany and India about major traffic drops being noticed from the Google Image search referral.

Martin Missfeldt who watches Google Image search like a hawk covered the issue in German on his blog.

In short, when you try to access an image in Google Image search in Germany, the frame loads a white blank page, which clearly can have an impact on suspected and inferred Google referrals. Here is a picture that I was able to replicate on Google.de:

Google Germany Image Search Bug

He even showed a chart that shares the pretty devastating traffic drop:

Google Image Traffic Shows Significant Drops

But Google USA doesn't render images like Google Germany, so the bug isn't an issue in the US.

John Mueller from Google chimed in on Martin Missfeldt's Google+ post and said "Thanks for the message, Which does not look good ...: /" (that is the translated version).

Martin also noted that Image Search seems to be indexing images way faster now.

There is a large thread about this in the Germany Webmaster Forums and Abakus Forums.

Forum discussion at Google+, Google+, Germany Webmaster Forums and Abakus Forums.

UPDATE: Google fixed the bug, around HTTPS/HTTP and it now is working again.

Previous story: Google Search Queries Report Goes Offline Today
 
blog comments powered by Disqus