Logos Disappearing From Google Local Listings

Jan 27, 2021 • 7:11 am | comments (1) by twitter | Filed Under Google Maps
 

There are a number of reports in the Local Search Forum that businesses are seeing their logos disappear from their Google local listings in search. I currently see mine so maybe it was a temporary glitch and it is now fixed.

Here is a screen shot of my Google local listing with an arrow pointing to the logo location:

Google added support for these logos back in June 2019.

Here are some of the complaints from the other day in the Local Search Forum:

Is anybody else noticing that logos are being removed from GMB profiles? I have 15 GMB profiles in my account and over the last week all have been removed.

Yes 15 of our clients have the same issue. I have also seen insight data not available for the past few days, wondering if anyone else has had this issue?

My client insights appear to be working ok. Just logos strangely

One reported this morning that their logos have returned but another issue with photo views. I do not see the photo views issue either...

Just an FYI, my logos went missing too but are back today. But now all my other photos say “no views” despite previously having 1000s... So you might want check that too. I guess eventually that’ll get corrected as well. Oh dear :)

Google My Business is known to be buggy...

Forum discussion at Local Search Forums.

Previous story: Daily Search Forum Recap: January 26, 2021
 
blog comments powered by Disqus