Firefox 3.5 Now Supported by Google AdWords

Jul 2, 2009 • 9:34 am | comments (1) by twitter Google+ | Filed Under Google AdWords

On June 30th, Mozilla released Firefox 3.5. On June 30th, we had the first complaints at Google AdWords Help that the Google AdWords interface was not supported in Firefox 3.5.

The error message being displayed to AdWords advertisers was:

Support for Firefox 3.5 is coming soon. Until then, please use an earlier version of Firefox when viewing the new interface.

Google fixed it a day later, and we have confirmed reports in that thread that the new AdWords interface is fully operational in Firefox 3.5. Oh, and by the way, it is also now working in Safari 4.0.

Forum discussion at Google AdWords Help .

Previous story: Google Finally Drops Call Tracking Phone Numbers?
blog comments powered by Disqus