Yahoo Site Explorer Link Bug Fixed?

Nov 1, 2010 • 7:57 am | comments (4) by twitter Google+ | Filed Under Yahoo Search Engine Optimization
 

A couple weeks ago, we reported that Yahoo Site Explorer suffered a major link drop site wide. So when webmasters and SEOs checked their links within Site Explorer they found a fraction of the links of what they are accustomed to see.

Yahoo said then that they are working on a fix.

Some are now reporting their link counts within Site Explorer are now back to normal.

The WebmasterWorld thread has one SEO saying, "Everything seems to have gone back to normal now." That comes from a senior member at the forum.

I do not see anyone else reporting this and personally, I do not track my link numbers in these tools - so I am not sure if there ever was a problem.

Forum discussion continued at Yahoo Suggestion Board, WebmasterWorld and DigitalPoint Forums.

Previous story: Halloween Logos From Google, Yahoo, Bing & More: 2010 Scooby Doo Edition
 

Comments:

M. Herman

11/01/2010 02:40 pm

Yeah, I saw totals return to normal last Thursday after about a 80% return to normal the day before, on Wednesday.

Mirna

11/07/2010 08:18 am

Good News!! I was about to confirm that yahoo site explorer is done on its service. It is a good thing that it has recovered.

Emma

11/12/2010 12:02 pm

I have dropped over 50% on many of my sites today, have they un-fixed it?

Sammy

11/19/2010 09:09 am

Ok has any1 noticed that site explorer is not working again, went on late last nite and was missing like 6000 backlinks, and the same with all other websites. Im sick of yahoo doing this to us all :(

blog comments powered by Disqus