Google Webmaster Tools Incorrectly Reporting Some 404 Errors

Jul 31, 2008 • 8:01 am | comments (4) by twitter Google+ | Filed Under Google Search Engine Optimization

Google 404 Errors Not RightA Google Groups thread has confirmation from Google that Google's Webmaster Tools may be reporting incorrect 404 status reports.

In fact, for this site, Google has reported over a 150 pages not found, in the webmaster tools section. The fact is, most of those pages are not reporting a 404 error and are functioning just fine. I have a screen shot of one of the pages of the report at Flickr. One of the 150 or so reported URLs by Google is this one of Guy Kawasaki's keynote at WebmasterWorld. If I plug in that URL into a http header checker tool, it returns a HTTP Status Code: HTTP/1.1 200 OK, not a 404.

In any event, JohnMu of Google said that they are working on it:

It's come to our attention that some URLs are listed as 404s for some sites in Webmaster Tools even though they were apparently crawled correctly. In general, even if we were not able to crawl some URLs correctly once or twice, this should not affect a site's crawling, indexing or ranking in our search engine.

We're currently analyzing the situation and will give you more information as soon as we have it.

He did say that this "should not" affect your actual rankings. It does seem to appear the above page I mentioned is ranking in Google just fine.

Forum discussion at Google Groups.

Previous story: Daily Search Forum Recap: July 30, 2008
blog comments powered by Disqus