Google Is Dropping Pages Out Of The Search Index; A Bug?

Apr 5, 2019 • 7:48 am | comments (119) by twitter | Filed Under Google Search Engine Optimization
 

Something weird is going on with the Google search index. I am seeing wide spread reports of SEOs and webmasters complaining that their URLs and web pages are being removed from the Google Index. Lots of folks are noticing that a nice percentage of their web sites are no longer coming up for a site command or showing in Search Console as being indexed.

You can use the fetch feature and once you do that, the page should return back in the index almost immediately but if 50% of your pages have been dropped, that might take a while to do.

A WebmasterWorld thread has a ton of complaints and I am seeing tons of threads in the official Google Search Console forums as well. And yes, folks on Twitter are noticing issues and posting as well.

Here are some quotes but there are tons of complaints in the forums, I can't quote or link to them all:

Me Too Spiekerooger but see my post above yours. I am also from germany and the reason could be, that the pages are not anymore in the index. It looks like there is some error in the google serps. see for example:

Yes, I see the same across many big domains. URL of home page suddenly dropped from google index. No changes to meta or robots.txt done. Search Console -> URL Inspection -> Live Test gives a good looking screenshot. No message of manual action.

Yep, that's what I'm seeing as well. And it's not on all datacenters by google. You see at least two different sets of serps w/ gone pages or not every other minute.

check if the pages are indexed. For all positions we have lost, the site: command gives no result anymore and I hope, when google has fixed this, the rankings will come back.

what the heck, you are right: 50% dropped of the index

Looks like the indexes are misbehaving still. I see that the indexes are intact in one machine where as in an another machine, it isn't there.

Many on Twitter also:

John Mueller is starting to get wind of this:

This is not just about pages not showing up for site commands, it seems like pages are not ranking anymore and traffic is being impacted.

I suspect this is some sort of bug with Google's index but we have not heard anything official from Google.

For now, just know, you are not alone and I will try to dig up more information for you all.

Forum discussion at WebmasterWorld and Google Search Console forums.

Update: This was fixed Saturday, April 6th. Google won't say what happened but it seems there was a bug that caused this. Here are John's tweets:

Sunday Update: It is still ongoing but should be addressed soon:

Update 3: Still waiting on Google fixing the issue - I have a new cleaner story over here on the issue.

Update 4: Google is almost fully done resolving the issue, we have an update on April 9th at 8:30am over here.

Previous story: AMP Stories Thumbnails In Google Search Results Snippets
 
blog comments powered by Disqus