Bug? Google Maps Drops Owner Uploaded Photos

Feb 10, 2012 • 8:44 am | comments (6) by twitter Google+ | Filed Under Google Maps
 

This is pretty scary, if you go to your Google Maps business listing, any photos you may have uploaded seem to have been completely removed! This even happened on my business listing where I had a ton of photos uploaded by yours truly and they are all gone.

Here is the backend where it shows I have zero photos uploaded:

Google Maps Photos Uploaded 0

Here is a picture only showing pictures from the web and not pictures I've uploaded:

Google Maps Photos Gone

Vanessa from the Google Maps team said they are looking into the bug. She said:

We're investigating to see if there's a bug going on. Keep posting your examples -- links to Place pages are most helpful.

To submit your issue, go to the Google Places Help forum and give Vanessa your URL.

Forum discussion at Google Places Help.

Previous story: Google Search Requiring Cookies? Google Says No
 

Comments:

seogear

02/10/2012 02:24 pm

Thanks for sharing such an interesting information. I will add the article to your bookmarks andwill advise friends to read.

Jon

02/10/2012 07:23 pm

I have not seen this in Canada (Toronto)

Lisa

02/11/2012 08:14 am

I haven't seen this in Australia. Hope it doesn't become another thing to make Places not as 'easy' as Google say it's supposed to be !

AussieInspire

02/11/2012 09:23 am

Ageed.

Jryan1151

02/11/2012 02:02 pm

big deal - just another Goggle bug - what's new?

SEO Journalist

02/11/2012 10:07 pm

 Agreed, there are dozens of small bugs in Google, but this one has gotten more publicity.

blog comments powered by Disqus